Testing 1.3.6, probably bugs? need help

Forum
Last Post
Threads / Messages

River cat

Member
Member
Joined
May 26, 2013
Messages
21
Points
1
Age
31
Location
Russia, Siberia (Omsk sity)
Mysidian Dollar
26
Hello!

I've installed 1.3.6 script and during test, found this problems:

1) item Function Alts1. When I use item with this function on my pet, it show broken page:
Fatal error: Uncaught Error: Call to undefined method Model\DomainModel\ItemFunction::applyAlts1() in /home/acapella/public_html/model/domainmodel/itemfunction.php:46 Stack trace: #0 /home/acapella/public_html/model/domainmodel/owneditem.php(99): Model\DomainModel\ItemFunction->apply(Object(Model\DomainModel\OwnedItem), Object(Model\DomainModel\OwnedAdoptable)) #1 /home/acapella/public_html/controller/main/inventorycontroller.php(45): Model\DomainModel\OwnedItem->apply('2') #2 [internal function]: Controller\Main\InventoryController->uses() #3 /home/acapella/public_html/resource/core/frontcontroller.php(196): ReflectionMethod->invokeArgs(Object(Controller\Main\InventoryController), Array) #4 /home/acapella/public_html/controller/main/indexcontroller.php(13): Resource\Core\FrontController->triggerAction() #5 /home/acapella/public_html/resource/core/frontcontroller.php(142): Controller\Main\IndexController->triggerAction() #6 /home/acapella/public_html/index.php(75): Resource\Core\FrontController->handleRequest() #7 /home/a in /home/acapella/public_html/model/domainmodel/itemfunction.php on line 46

Result with Alts2

Fatal error: Uncaught Error: Call to undefined method Model\DomainModel\ItemFunction::applyAlts2() in /home/acapella/public_html/model/domainmodel/itemfunction.php:46 Stack trace: #0 /home/acapella/public_html/model/domainmodel/owneditem.php(99): Model\DomainModel\ItemFunction->apply(Object(Model\DomainModel\OwnedItem), Object(Model\DomainModel\OwnedAdoptable)) #1 /home/acapella/public_html/controller/main/inventorycontroller.php(45): Model\DomainModel\OwnedItem->apply('1') #2 [internal function]: Controller\Main\InventoryController->uses() #3 /home/acapella/public_html/resource/core/frontcontroller.php(196): ReflectionMethod->invokeArgs(Object(Controller\Main\InventoryController), Array) #4 /home/acapella/public_html/controller/main/indexcontroller.php(13): Resource\Core\FrontController->triggerAction() #5 /home/acapella/public_html/resource/core/frontcontroller.php(142): Controller\Main\IndexController->triggerAction() #6 /home/acapella/public_html/index.php(75): Resource\Core\FrontController->handleRequest() #7 /home/a in /home/acapella/public_html/model/domainmodel/itemfunction.php on line 46


Need help, for solution!

Also, I will keep to post here, if I will find somthing else.
 

Hall of Famer

Administrator
Staff member
Administrator
Joined
Dec 15, 2008
Messages
4,502
Points
48
Location
United States
Mysidian Dollar
213,747
You are right, this is a bug. The methods applyAlt1() and applyAlt2() had typos, should be named applyAlts1() and applyAlts2() instead. Strange I didnt find this one when testing it myself, I've fixed it and posted an update to the main script download page.

I've fixed this issue on your own site too, for anyone else just download this file and upload it to your server /model/domainmodel/itemfunction.php.
 

Attachments

  • itemfunction.php
    8 KB · Views: 2

Similar threads

Users who are viewing this thread

  • Forum Contains New Posts
  • Forum Contains No New Posts

Forum statistics

Threads
4,162
Messages
32,369
Members
1,528
Latest member
XD_Stones
BETA

Latest Threads

Latest Posts

Top