Is there a way to allow 1.3.6 to use php 8.1?

Forum
Last Post
Threads / Messages

KittHaven

Member
Member
Joined
May 21, 2013
Messages
386
Points
18
Age
24
Location
Devon, UK
Mysidian Dollar
7,319
I'm trying to install a forum I found that I like but it requires php 8.1. Mysidia will only work with 8 max or it throws a bunch of errors.

2023-01-04 02_06_28-Greenshot.png


Is there a way to fix this? Thanks!
 

Kesstryl

Member
Member
Joined
Feb 22, 2012
Messages
142
Points
18
Mysidian Dollar
11,053
Try google searching these errors by highlighting and right clicking, then use the search google option and see what comes up. Sometimes Stackoverflow will give good answers. I ran into a depreciation like this on one of my other sites and got an answer that fixed it.
 

HIddenPanda

Premium Member
Premium Member
Joined
Jul 15, 2010
Messages
60
Points
8
Mysidian Dollar
3,648
Might be able to fix this by changing line 94 in resource\collection\collection.php to
PHP:
function count(): int {
and line 103 to
PHP:
function getIterator(): Traversable|array {
 

Hall of Famer

Administrator
Staff member
Administrator
Joined
Dec 15, 2008
Messages
4,552
Points
48
Location
United States
Mysidian Dollar
214,118
Its interesting, seems to be a notice error so it wont affect your live site. Mysidia does not use return type hinting though, so I am surprised you can get this error.
 

Similar threads

Users who are viewing this thread

  • Forum Contains New Posts
  • Forum Contains No New Posts

Forum statistics

Threads
4,214
Messages
32,630
Members
1,577
Latest member
pudgiehedgie
BETA

Latest Threads

Latest Posts

Top